What is a project in Advanced Web Ranking?

When working with Advanced Web Ranking, you have a wide range of choices: track rankings, your backlinks and social shares, evaluate traffic or research new keywords. To gather all this information and connect it with your website, you need to define a project.

How to create a new project

To create a new project, you have two options:

  • Go to Projects menu and click the Add button from the top menu.
  • Click on the projects drop down list from the top-left corner and click the + button.

Both ways, Advanced Web Ranking will start the New Project Wizard. After completing the wizard, the newly created project will appear in your projects list along with the existing.

How many projects can I create?

There are no limitations for the number of projects you can create and manage with Advanced Web Ranking. Likewise, you can add an unlimited number of keywords, websites and search engines to your AWR projects and track your performance.

How to see and edit my list of projects

The Project Manager provides you with an overview of all your created projects with details for each project. To access the Project Manager simply go to Projects menu and here you can use the Add/Remove options from the top menu.

How to delete a project

If you wish to remove any of the listed projects from your application, you can do it from the Projects menu, using the Remove button. It will enable a mode that allows you to mark the projects for deletion and then you must Confirm removal for a permanent removal of the selected projects.

Please note that all the available information related to that project will be permanently removed from your hard drive.

How to delete all the data associated with a project but keep the websites, keywords and search engines in place

You can Reset a project by using the Data -> Reset Data left-side menu. All the data for that project will be lost. The only things that are kept are the keywords, the Websites and your selection of search engines.

How to delete specific updates from my projects

To delete the ranking data gathered for a certain project within a time range, you need to go to the Data menu, select Remove Data feature and specify the date range you wish to remove.

The Begin option sets the start date on the day the project was created, while the Last update date option sets the end date to the last day the project was updated.

The ranking data will be removed for the time period you have defined, including the starting and ending dates.

In a similar manner, you can remove from your project the link information gathered within a time range. For that, select the Remove Link Data feature from the Data menu and set the time period to be removed.

How to duplicate a project

To duplicate a project, go to the Projects menu, select the desired project from the list and click the Duplicate button at the top. The newly created project will have all the settings and ranking data as the original one, but with a different name that you will specify.

How to rename a project

You can easily change the name of an existing project by double clicking on its name, while in the Projects menu. Here select the project you want to rename and click the Rename project button from the top menu. An editing field will appear where you can just type your project's new name.

How to create/manage project tags

Projects can be organized using tags and displayed in the Projects menu. For that you must create new tags and assign them to your projects.

While in the Projects menu, click on the All projects button (next to the search box) -> New.

This will open en editing mode that gives the possibility to check the projects to which you want to add this tag. When you are done selecting click on Save new tag? and enter a name for your new tag.

How to backup my projects and data

To keep your projects safe and avoid data loss, you can create backups for your projects and save them on an external location. The backup will contain all the project inputs (keywords, websites and search engines) and all gathered data (rankings, links, analytics and social metrics) and can be restored at any time.

To create a project backup, you have two options:

  • While in the Project Manager, select the desired project and click the Backup button at the top.
  • Go to Data -> Backup & Restore menu, select the desired project and click the Backup button.

By default your project backups are saved on your computer, in the \AWR User Data\backup folder. You can change this path from Data -> Backup & Restore menu and select any location on your computer you prefer.

How to restore a project from backup

To restore a project that you have previously backed up, you need to go to the Data -> Backup & Restore menu and navigate to the folder containing your project backup. The default backup folder will be already selected.

The list of projects will be populated with all the project backups found at the location you specified and you just need to select the desired project and press the Restore button at the right.

The project that you choose to restore will be added to your active projects list.

If you restore a project that already exists, the overwrite option will NOT merge the restored project with the existing project. It will completely replace the existing project with the backed-up project.

How to schedule AWR to automatically backup my projects

With Advanced Web Ranking you can automatically backup your projects and rest assured that you will never lose your data. To schedule your project backups, you need to enter the Scheduler menu. Here click the New button and select "Schedule backup". You have three options:

  • Backup the current project
  • Backup a specified project
  • Backup multiple projects

Your project(s) will be archived to take less space and then stored in a special folder called "backup" inside the data folder.

How to get fresh rankings for my projects

To gather fresh data for your project, you need to update it.

How to import Web Position Gold projects into Advanced Web Ranking

You can import your old Web Position Gold projects into Advanced Web Ranking and use your historical data.

Go to Data -> Import -> Import Web Position Gold Projects menu, just click on the Browse button and select the folder where your Web Position Gold projects reside. You will be presented with a list of all the projects found in that folder. Select the projects you wish to import and then press the Import button.

If you are running Advanced Web Ranking on a Mac OS, you won't be able to import your Web Position Gold projects directly. Therefore you need to perform the following steps in order to import your Web Position Gold projects on your MAC:

  • Also install Advanced Web Ranking on the PC where your WPG resides and import the WPG projects there, following the instructions above
  • After importing the WPG files, generate backups for the new created AWR project(s)
  • Copy the backup files on your MAC (if the two computers you are using are on the same network, you can backup those projects, directly on the MAC)
  • Restore the backups on your MAC computer and you are done!

How to import data from Raven Tools into Advanced Web Ranking

You can import your old Raven Tools projects into Advanced Web Ranking and use your historical data.

Go to Data -> Import -> Import projects from Raven Tools menu, click on the browse button, select the archive of projects from Raven Tools and open it. Here you have listed the projects exported from Raven with the number of websites, keywords and search engines that they contain. Just press the Start Import button to have this information in the application.

Once this data is imported, the project is automatically added to the projects list in the application.

How to import projects from XML files

You can create hundreds or thousands of new projects instantly by importing them from XML files.

To perform the import, go to the Data -> Import -> Create projects from XML export menu and provide the path to the folder where the XML file is stored.

You can find the required XML templates following the links below:

Please, note that the XML file template contains only the settings for the projects that will be created (websites, keywords and search engines) but with no ranking data.

How to export projects to XML files

If you need to rapidly create a new AWR project with the same settings and inputs (websites, keywords and search engines) of an existing one, you can use the export to XML feature.

This feature enables you to export the inputs and settings of a project into an XML file that you can further use to create a new one.

To access this feature you need to go to the Data menu, select the Export Project Settings to XML option and define the location where the XML file will be saved.

How to export my project ranking data to a file

Advanced Web Ranking allows you to export the rank data that it gathers to a CSV or XML file.

The data export uses the same mechanism as the printable reports, so you can create a custom export template and export the data with it whenever you choose to.

You can also use the scheduler to make the data export at a certain date and time and assign your own custom application to be run after the export is complete, so that the data can be parsed and changed into the format you require.

With the Data Export feature from Advanced Web Ranking, you can export Websites Rankings and Top Sites data.

For this, you must go to the Data -> Export menu and create the template you wish to use for the export, by clicking on the New Export button.

How to import projects from CSV files

Advanced Web Ranking can import projects from CSV files. It can import either from CSV files created by exporting Rank Data from AWR, or files exported by another application.

To start the Import Wizard go to the Data -> Import -> Import from CSV menu

In the first step of the import wizard, you can choose:

  • the CSV file path
  • the file encoding
  • the separator
  • you can specify if the CSV file contains or not the header on the first line. If the CSV file contains the header on the first line, this will help at the next step, when selecting the columns by name
  • a character to delimit text data
  • the rank highest position: some start the ranking with 0, others with 1
  • you can import the data into the current project or into a new one.
Import CSV

In order for a CSV file to be importable from AWR it must have the following columns:

  • Search Engine
  • Keywords
  • Website
  • Position
  • Date
  • Page (Optional)

The date format used in the CSV file must be specified in order to have valid dates in your project.

You also need to assign to each section the number of the matching columns from the file being imported and make sure the date format is set accordingly:

Import CSV

According to the selection from the previous step (input columns - search engine), all the search engines found in the CSV file are listed. These search engines must be synchronized with the AWR search engines, as the CSV file can originate from another application and the names can be different.

Import CSV

When you encounter this case, just press on the selector icon and chose the relevant search engine for your project.

According to the selection from the second step (input columns - keywords), all the keywords found in the CSV file are listed. You can select these keywords and change their properties - color, index, priority.

At the next step, you can select these websites and change their properties - color, index, stop if found.

At the final step, you must choose a name for the project. On Finish, the project is created containing the search engines, keywords and websites selected at the previous steps, as well as websites ranking.

How reliable is the product and its data, and is it possible to backup the software and its information?

Advanced Web Ranking stores its data in a relational database which employs transactions for each action. If a transaction fails, the database will restore itself to avoid being corrupted.

To be safe, the application allows you to backup all the projects whenever you need. You can also create a scheduled task that will backup all your projects as often as you want: daily, weekly, monthly.

How to import/export data between different versions of the software

Importing the data from previous versions of the applications is done automatically. There is nothing you need to do about this, because the application will automatically take care of it for you.

If you wish to move a project from one computer to another, all you need to do is backup the project and then restore it on the other computer.